Quick Links:
Help Topics Commands Index Custom Apps Save & Print

CAS

A computer algebra system or CAS is a representational toolkit that allows one to manipulate symbolic expressions and equations, to compute results in approximate and exact forms, and to create, move between, and transform linked graphic and numeric representations of functions.

Tools

  • The Home tab (shown at left) can be used to define, calculate, and manipulate numerical and algebraic expressions and equations through commands.
  • The Y= tab is used to define explicit or implicit functions (equations) to be manipulated or represented as tables or graphs.
  • The Settings tab becomes available when at least one equation has been defined and selected in the Y= menu.
  • The Table and Graph tabs display representations of all defined and selected equations specified in the Y= tab.
  • The Data tab is accessible by choosing File | Data in the Home tab.

 

Home

Type into the Command line and press Enter to execute a command. Each entry will be recorded above in the History. Click on a result in the History and press Enter to re-enter it into the Command line.

Note: Some equations defined as explicit or implicit functions in the Command line (e.g., those involving function notation, or the variables x and y among others) will also be recorded in the Y= menu.

See also Algebra & Functions Commands.

Symbolic Manipulation

The Algebra and Functions menus, and Options | Math Toolbar entries from the Home tab give common commands to use for CAS. Click here for explanations and examples of these commands in use.

Type +, -, *, /, ^ to substitute the last expression into an additional expression in the Command line.

Example. Keystrokes used in Command line: 3x+11=5x+7 [Enter] -3x [Enter] -7 [Enter] /2 [Enter]. Recorded in History: 3*x+11=5*x+7; 11=2*x+7; 4=2*x; 2=x.

A common error displayed in the History is "Syntax error," which indicates that the symbols used in the previously entered command may be out of order, missing, or inappropriately used. Check for correct spelling and use of parentheses.

Settings

Setting the mode and default display of computations is done using the Home | Options menu.

See also Settings for Graphs and Tables.

Matrices

Use the Home tab Matrices menu to define new matrices, edit existing matrices, perform matrix computations, and view matrices as vertex-edge graphs.

There are several ways to define new matrices:

To edit a matrix:

To compute with matrices type into the Command line or use the Matrix | Functions menu. Click below to view an explanation of a command and see examples of its use:

matrix(), inv(), det(), id(), tr(), size(), row(), col().

View a matrix as a Directed or Undirected Vertex Edge Graph by choosing the desired entry from Home | Matrices | View Matrix As. The selected matrix will be treated as an adjacency matrix and will be represented as a vertex-edge graph in a new window.

See also Advanced Apps | Vertex-Edge Graphs.

 

Y=

The Y= tab is used to define, select, and edit equations and functions that can later be viewed in the Table or Graph tabs.

Define Equations and Functions

In general, any explicit or implicit equality or inequality that relates variables is an allowable function that may be defined in either the Y= tab or the Home tab. Some Help Tips are included below:

Select and Edit Equations and Functions

Type into the Y= Command line end press Enter; it will be listed below. Options to box and select equations/functions include:

Settings and Plot Options

When an equation has been defined, a pull down options menu becomes available to its left. Use this menu to select from Rectangular, Polar, Parametric, or 3D plot options.

See also Home | Settings, Settings tab.

 

Settings

The Settings tab allows you to modify the window options and plot styles that pertain to the Graph tab and Table tab. The Settings tab applies to all functions defined and selected in the Y= tab. Available options depend upon whether a function is 2D (explicit or implicit) or 3D.

Note: A check mark must be next to at least one equation/function within the Y= tab for the Settings tab to be available.

See also Home tab Settings.

Options

Quickly modify settings for graphs and tables with the Options menu.

2D Functions

The 2D Functions tab within the Settings tab pertains to all selected functions that are defined explicitly from within the Y= tab (e.g., the dependent variable is written as a function of the independent variable such as y=x+2).

Note: If Options | Simultaneous is not checked, then each explicitly defined function will have its own sub tab to adjust settings individually.

The Implicit sub tab within the Settings tab pertains to all selected functions that are defined implicitly from within the Y= tab (e.g., 4x+y=8). Minimum and maximum x and y values can be set for this type of 2D Function.

3D Plots

Settings for 3D Plots can be changed for each plot that is defined. Values for minimum and maximum X, Y, and Z coordinates can be changed for both the View Bounds and Graph Bounds.

 

Tables

The Table tab becomes available once an explicitly defined 2D Function or a 3D Plot is selected within the Y= tab. The settings that were determined within the Settings tab apply to the Table tab. Some Help Tips are include below:

See also Settings | Options.
See also Save & Print.

 

Graphs

The Graph tab becomes available once a function is defined and selected within the Y= tab. The window settings that are chosen from within the Settings tab determine the initial graphical display. Also use the Zoom and View Options to customize the display.

Note: To trace (i.e., view the coordinates of points) a graph move the cursor over the graph.

See also Save & Print.

Zoom Settings

Determine the Window in the Settings tab or use the Graph tab Zoom menu:

Graph View Options

Options menu:

Slice 3D Plots

The Slice menu of the Graph tab is only available when viewing 3D Plots. It allows you to position a slicing plane, parallel to either the x-y plane, y-z plane, or x-z plane, and examine how the slicing plane intersects the 3D plot(s).

 

Data

To view a data tab, choose File | Data in the Home or Y= tab.

Help topics on Data sheets are available in the Data Analysis Help. Note however that Data tab functionality is slightly different than the Data Analysis tool: