Quick Links:
Help Topics Custom Apps Save & Print Index Catalog

Vertex-Edge Graph

A collection of vertices and edges, draw your own or create sample vertex-edge graphs. Add color, weight, and direction to a graph, run tests and algorithms, and investigate the adjacency matrix representation of a graph.


Vertex-Edge Graphs

A vertex-edge graph is a diagram consisting of a set of points (called vertices) along with segments or arcs (called edges) joining some or all of the points. The positions of the vertices, the lengths of the edges, and the shape of the graph are not essential. Important features of a graph include color, weight, direction, and how vertices are connected by edges.

 

Drawing Vertex-Edge Graphs

 

Pre-Constructed Graphs

Sample Graphs menu

This menu provides pre-constructed vertex-edge graph examples that are organized based on graph type. When a graph is chosen, it will be displayed in a separate window and may be edited and modified if desired. Some of the options are described here:

 

Editing Graphs and Style Options

Once a vertex-edge graph has been drawn (or selected from the Sample Graphs menu) there are various style and edit options that you may choose to utilize. As detailed below, the selection tool, Edit menu, and Options menus are the prominent features available for editing graphs.

 

Options menu

The Options menu offers various editing options to set edge type, vertex border, and graph display. See the Adjacency Matrix section for detailed help topics related to adjacency matrices.

 

Edit menu

The Edit menu offers stylistic options for existing graphs. Most menu options are also available as toolbar buttons.

 

File Options

The File menu offers options to open, save, and print new and existing work.

See Save & Print for help on Save, Print, and Open options.

 

Adjacency Matrix

An adjacency matrix is a matrix representation of a vertex-edge graph in which each entry of the matrix indicates whether the corresponding pair of vertices are connected by any edges (or rather, are adjacent). Each entry of the matrix represents the number of directed edges connecting the row vertex to the column vertex. A zero (0) indicates that the vertices are not adjacent.

 

Tests & Algorithms

Tests menu

To test a drawn graph or network, choose an option from the Tests menu. A separate message box will display the result of the test. If the test was successful, the message box will list the appropriate vertices used for the chosen test.

Algorithms menu

The Algorithms menu offers several different types of algorithms that can be used after a graph or network is drawn. An algorithm is a list of step-by-step instructions or a systematic step-by-step procedure. General instructions for how to run an algorithm are provided below, followed by a list of possible algorithms.

How to Run an Algorithm For a Drawn Graph:

  1. Choose Automatic or Step Through in the Algorithms menu to determine the way the algorithm will be completed. A check mark will appear next to the selected option.
  2. Select any of the available algorithms that are listed in the Algorithms menu to perform that algorithm on the drawn graph.
    Important Note: Be sure that only one type of procedure and algorithm are selected at once; uncheck any unwanted options by clicking on them.
  3. The chosen algorithm will run as Automatic or Step Through (depending on the choice made in Step 1). See below for algorithm-specific help topics.

 

Algorithms